Фоновые задания в http-сервисах OneScript

Программирование - Практика программирования

В статье описана библиотека, реализующая механизм фоновых заданий в http-сервисах OneScript, а также некоторые обновления платформы 1.0.19

 

Введение

При разработке приложений, периодически возникают задачи, требующие одновременного  выполнения нескольких процессов. В платформе 1С:Предприятие данная функциональность реализована при помощи механизма фоновых заданий. В стандартной поставке OneScript данная функциональность отсутствует, поэтому целью настоящей статьи является описание библиотеки, которая реализует механизм фоновых заданий в web-приложениях (http-сервисах) OneScript.

 

Описание

Библиотека реализует типы МенеджерФоновыхЗаданийWeb, СостояниеФоновогоЗадания и ФоновоеЗаданиеWeb, которым в платформе 1С:Предприятие соответствуют типы МенеджерФоновыхЗаданий и ФоновоеЗадание соответственно.

Реализованные типы

МенеджерФоновыхЗаданийWeb

Методы:

  • Выполнить
  • ОжидатьЗавершения
  • ПолучитьФоновыеЗадания

ФоновоеЗаданиеWeb

Свойства:

  • ИмяМетода
  • ИнформацияОбОшибке
  • Ключ
  • Конец
  • Наименование
  • Начало
  • РазделениеДанных
  • РегламентноеЗадание
  • Состояние
  • УникальныйИдентификатор

Методы:

  • ОжидатьЗавершения
  • Отменить
  • ПолучитьСообщенияПользователю

СостояниеФоновогоЗадания

Аналогичен соответствующему типу в 1С:Предприятие.

 

Отличия от платформы 1С:Предприятие

Библиотека практически полностью совместима с платформой 1С:Предприятие на уровне кода, однако все-же имеются незначительные отличия:

ФоновыеЗаданияWeb.ПолучитьФоновыеЗадания

В отличие от 1С:Предприятие, где фоновые задания хранятся в информационной базе и Вы можете получить примерно 1000 последних фоновых заданий, запущенных на выполнение, текущая реализация библиотеки имеет динамический список выполняемых заданий. Задания помещаются в список при вызове метода Выполнить и удаляются после завершения фонового задания. Таким образом, в отличие от 1С:Предприятие, метод возвращает фоновые задания, которые выполнялись на момент вызова метода или были завершены, но еще не удалены из списка.

ФоновоеЗаданиеWeb.РазделениеДанных

Всегда возвращает пустую структуру

ФоновоеЗаданиеWeb.РегламентноеЗадание

Ввиду отсутствия регламентных заданий, всегда возвращает Неопределено.

ФоновоеЗаданиеWeb.Отменить

Ввиду особенностей реализации, вызов этого метода не приводит к каким-либо действиям (задание продолжает выполнение и не отменяется).

ФоновоеЗаданиеWeb.ПолучитьСообщенияПользователю

Всегда возвращает пустой фиксированный массив.

 

Установка

Предварительные условия

Для использованиия настоящей библиотеки, необходимо установить обновление платформы OneScript, которое улучшает многопоточность http-сервисов OneScript.

Обновление для OneScript версии 1.0.19  можно скачать по нижеследующей ссылке: ASPNETHandler-v1.1-1.0.19.zip . Установка производится простым копированием содержимого архива, поверх файлов поставки OneScript.

Описание обновления, а также сопутствующих библиотек доступно по ссылке.

 

Установка библиотеки

Установка осуществляется копированием файлов dll в папку Bin веб-приложения. Затем, необходимо подключить библиотеку, добавив нижеследующую строку в секцию <appSettings>, файла web.config:

<add key="WebBackgroundJobs" value="attachAssembly" />

Настроить интервал проверки состояния фоновых заданий для метда ОжидатьЗавершения, можно добавив в раздел <appSettings>, файла web.config нижеследующий ключ:

<add key="jobsCheckInterval" value="5000" />

Интервал задается в миллисекундах. Интервал проверки по умолчанию (если ключ не установлен) составляет 1000 миллисекунд.

 

Использование

Ниже приведен фрагмент кода, иллюстрирующий работу библиотеки:

// Создаем объект менеджера фоновых заданий. Только для OneScript
//<OneScript>
ФоновыеЗадания = Новый МенеджерФоновыхЗаданийWeb;
//<!OneScript>

// Запускаем фоновые задания на выполнение
	
МассивПараметров = Новый Массив;
МассивПараметров.Добавить(1);
МассивПараметров.Добавить("1.txt");
	
ФоновыеЗадания.Execute("Тестовый.ТестовоеФЗ", МассивПараметров, "Ключ1", "Описание1");
	
МассивПараметров = Новый Массив;
МассивПараметров.Добавить(1);
МассивПараметров.Добавить("2.txt");
	
ФоновыеЗадания.Execute("Тестовый.ТестовоеФЗ", МассивПараметров);

// Получаем все выполняющиеся задания
МассивЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания();

// Ожидаем завершения выполнения запущеных заданий
ФоновыеЗадания.ОжидатьЗавершения(МассивЗаданий);

// Продолжаем выполнение

 

Заключение

Надеюсь, что использование настоящей библиотеки, совместно с библиотеками обработки контента , работы с субд и кэширования данных, позволят вам создавать “взрослые” web-приложения на базе каркасной конфигурации, которые совместно с 1С:Предприятие, позволяют решать реальные бизнес-задачи ваших клиентов.

Скачать файлы

Наименование Файл Версия Размер
Библиотека, реализующая фоновые задания:
.zip 6,80Kb
28.03.18
2
.zip 6,80Kb 2 Скачать

См. также

Комментарии
Сортировка: Древо
1. starik-2005 1386 29.03.18 12:39 Сейчас в теме
А sleep в oneScript'е есть? А то без него управление многопоточными вычислениями мягко говоря ущербно...
2. blackhole321 710 29.03.18 12:43 Сейчас в теме
(1)sleep есть, называется Приостановить. Честно говоря и без sleep ничего ущербного не вижу. Если не секрет -зачем создавать поток и стоить его?
3. blackhole321 710 29.03.18 12:44 Сейчас в теме
4. starik-2005 1386 29.03.18 12:50 Сейчас в теме
(3) стопить не поток, а управляющую процедуру, чтобы не проверять мульон раз в секунду, завершился у меня расчет в потоке или нет. Т.е. так как-то:
  Пока ЕстьПотоки() Цикл
  Если ЕстьЗавершенныйПоток() Тогда
    Данные = ПолучитьСледующуюПорциюДанных();
    Если Данные = Неопределено Тогда
      Прервать;
    КонецЕсли;
    ДобавитьВСписокФЗ(
      ФоновыеЗадания.Выполнить("МодульФЗ.ОбработкаДанных", ПолучитьЗначениеВМссиве(Данные), ...)
      );
   КонецЕсли;
   Подождать 10мс;
  КонецЦикла;
  ДождатьсяЗавершенияВЗ();
Показать
sasha777666; +1 2 Ответить
5. blackhole321 710 29.03.18 13:04 Сейчас в теме
(4) Понятно. Можно в самом потоке, при завершении инициировать новый поток, если остались данные для обработки.
6. starik-2005 1386 29.03.18 13:09 Сейчас в теме
(5)
если остались данные для обработки.
Тогда это не параллельность, а последовательное выполнение. Смысл теряется...
7. blackhole321 710 29.03.18 13:14 Сейчас в теме
(6) Ну почему же, Вы можете сделать столько потоков, сколько элементов данных, подлежащих обработке (по крайней мере несколько, если у Вас некий пул), также, как Вы делаете в цикле, только в самих потоках.
8. starik-2005 1386 29.03.18 13:19 Сейчас в теме
(7) а микросекундный sleep есть?
9. blackhole321 710 29.03.18 13:32 Сейчас в теме
(8)Думаю - нет, ведь и Linux и Windows не ОС реального времени, в Windows квант времени ~10-20 миллисекунд, поэтому даже если написать Sleep(1), то задержка будет > 1 мс.
10. blackhole321 710 29.03.18 13:33 Сейчас в теме
(8) А если не секрет, зачем Вам такие малые задержки?
11. blackhole321 710 29.03.18 13:55 Сейчас в теме
(8) Вот есть к примеру такая реализация микросекундного таймера https://www.codeproject.com/Articles/98346/Microsecond-and-Millisecond-NET-Timer , которую не сложно перенести, однако, как отмечает сам автор, если использовать в не real-time ОС, периодически интервалы будут неверными.
12. starik-2005 1386 29.03.18 14:23 Сейчас в теме
(11) периодические интервалы тут не особо критичны. Фактически если у Вас N заданиий, которые обрабатывают по M блоков, то массив из Х блоков они обработают за Х/M/N раз. При том если элемент данных обрабатывается за разное время, то некоторые блоки должны будут обработаться раньше, чем другие, и ДождатьяЗавершения будет ждать самый долгообрабатываемый блок. Для того, чтобы загрузить новые процессы данными, нужно их стартануть с новым массивом обрабатываемой информации. Если ждать секунду (как в 1С, когда народ юзает "ping localhost"), то за секунду можно некоторое количество элементов уже обработать. Поэтому хорошо бы ждать 1/10-ю секунды, например. И на сколько это в миллисекундах точно - второй вопрос, главное чтобы в это время процессор просто ждал...
13. blackhole321 710 29.03.18 15:19 Сейчас в теме
(12)
Если ждать секунду (как в 1С, когда народ юзает "ping localhost"), то за секунду можно некоторое количество

Ну 1/10 секунды - это 100 миллисекунд, что вполне нормально и для Sleep, который уже есть. И это будет действительно приостановка выполнения. Вот описание метода, который реализует Sleep в OneScript https://msdn.microsoft.com/ru-ru/library/system.threading.thread.sleep(v=vs.110).aspx

Моя изначальная мысль была в том, что можно запускать потоки для обработки новых порций данных из самих потоков, примерно так:

Процедура МоеФЗ(ДанныеДляОбработки) Экспорт
	
	// Что-то делаем
	
	Отбор = Новый Структура;
	Отбор.Вставить("Состояние", СостояниеФоновогоЗадания.Активно);
	Отбор.Вставить("ИмяМетода", "МойМодуль.МоеФЗ");
	МассивЗаданий = ФоновыеЗадания.ПолучитьФоновыеЗадания(Отбор);
	
	МаксКоличествоПотоков = 5;
	КоличествоПотоков = МаксКоличествоПотоков - МассивЗаданий.Количество() + 1;
	
	Для Индекс = 1 По КоличествоПотоков Цикл
		
		ДанныеДляОбработки = ПолучитьСледующуюПорциюДанных();
		
		Если ДанныеДляОбработки = Неопределено Тогда
			Возврат;
		КонецЕсли;
		
		МасиивПараметров = Новый Массив;
		МассивПараметров.Добавить(ДанныеДляОбработки);
		ФоновыеЗадания.Выполнить("МойМодуль.МоеФЗ", МассивПараметров);
		
	КонецЦикла;
	
КонецПроцедуры
Показать
Оставьте свое сообщение